diff options
author | Alexandre Vassalotti <alexandre@peadrop.com> | 2008-05-06 19:48:38 (GMT) |
---|---|---|
committer | Alexandre Vassalotti <alexandre@peadrop.com> | 2008-05-06 19:48:38 (GMT) |
commit | 77250f4df7a73a5c87d12d781a562747a855cd95 (patch) | |
tree | 61f83259cd270f6011c75cbe95d2a25d12c29f87 /setup.py | |
parent | 5d8da20dd1034081906dbdffea9c77bf39353dec (diff) | |
download | cpython-77250f4df7a73a5c87d12d781a562747a855cd95.zip cpython-77250f4df7a73a5c87d12d781a562747a855cd95.tar.gz cpython-77250f4df7a73a5c87d12d781a562747a855cd95.tar.bz2 |
Added fast alternate io.BytesIO implementation and its test suite.
Removed old test suite for StringIO.
Modified truncate() to imply a seek to given argument value.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -426,6 +426,8 @@ class PyBuildExt(build_ext): exts.append( Extension('operator', ['operator.c']) ) # _functools exts.append( Extension("_functools", ["_functoolsmodule.c"]) ) + # Memory-based IO accelerator modules + exts.append( Extension("_bytesio", ["_bytesio.c"]) ) # atexit exts.append( Extension("atexit", ["atexitmodule.c"]) ) # Python C API test module |