summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-17 08:35:56 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-17 08:35:56 (GMT)
commit8a59113bf5b7848ccf1efd215387e0ce3763ae48 (patch)
tree287e8f4e81e7cb7272421f52aff702e02e6baa88 /setup.py
parent664b511c0acdfdecdec92d2255ffd94c4e6d5f7a (diff)
downloadcpython-8a59113bf5b7848ccf1efd215387e0ce3763ae48.zip
cpython-8a59113bf5b7848ccf1efd215387e0ce3763ae48.tar.gz
cpython-8a59113bf5b7848ccf1efd215387e0ce3763ae48.tar.bz2
Merged revisions 76865 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r76865 | mark.dickinson | 2009-12-17 08:33:56 +0000 (Thu, 17 Dec 2009) | 1 line Add _math.h to math module dependencies in setup.py. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3666e8f..c2c0af1 100644
--- a/setup.py
+++ b/setup.py
@@ -399,6 +399,7 @@ class PyBuildExt(build_ext):
# math library functions, e.g. sin()
exts.append( Extension('math', ['mathmodule.c', '_math.c'],
+ depends=['_math.h'],
libraries=math_libs) )
# time operations and variables
exts.append( Extension('time', ['timemodule.c'],