diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2001-02-21 02:38:24 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2001-02-21 02:38:24 (GMT) |
commit | cf393f3fd9759ffac71c816f97ea01780848512c (patch) | |
tree | baa91c10ea6ff05b4aa049039713ceab8bc6f451 /setup.py | |
parent | c5032194bea722fcdb98b0a443985be85c478e8b (diff) | |
download | cpython-cf393f3fd9759ffac71c816f97ea01780848512c.zip cpython-cf393f3fd9759ffac71c816f97ea01780848512c.tar.gz cpython-cf393f3fd9759ffac71c816f97ea01780848512c.tar.bz2 |
Patch #103544: always compile the dl and nis modules on Unix; let's see
where they break.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -362,9 +362,16 @@ class PyBuildExt(build_ext): if platform not in ['cygwin']: exts.append( Extension('resource', ['resource.c']) ) + # Generic dynamic loading module + exts.append( Extension('dl', ['dlmodule.c']) ) + + # Sun yellow pages. Some systems have the functions in libc. if (self.compiler.find_library_file(lib_dirs, 'nsl')): - exts.append( Extension('nis', ['nismodule.c'], - libraries = ['nsl']) ) + libs = ['nsl'] + else: + libs = [] + exts.append( Extension('nis', ['nismodule.c'], + libraries = libs) ) # Curses support, requring the System V version of curses, often # provided by the ncurses library. |