summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrett Cannon <bcannon@gmail.com>2004-06-24 01:38:47 (GMT)
committerBrett Cannon <bcannon@gmail.com>2004-06-24 01:38:47 (GMT)
commit057e7200d1c300f3c914dbc84eca327c10bf7751 (patch)
treeee618603a291b04e277560989e332541809b63cd /setup.py
parent6cc48148fe0ecd600f796031ecfd16813f7f0d1e (diff)
downloadcpython-057e7200d1c300f3c914dbc84eca327c10bf7751.zip
cpython-057e7200d1c300f3c914dbc84eca327c10bf7751.tar.gz
cpython-057e7200d1c300f3c914dbc84eca327c10bf7751.tar.bz2
Add compilation of timemodule.c with datetimemodule.c to get
__PyTime_DoubleToTimet().
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cc163ea..8309008 100644
--- a/setup.py
+++ b/setup.py
@@ -315,7 +315,7 @@ class PyBuildExt(build_ext):
# time operations and variables
exts.append( Extension('time', ['timemodule.c'],
libraries=math_libs) )
- exts.append( Extension('datetime', ['datetimemodule.c'],
+ exts.append( Extension('datetime', ['datetimemodule.c', 'timemodule.c'],
libraries=math_libs) )
# random number generator implemented in C
exts.append( Extension("_random", ["_randommodule.c"]) )