diff options
author | Anthony Baxter <anthonybaxter@gmail.com> | 2004-10-13 15:54:17 (GMT) |
---|---|---|
committer | Anthony Baxter <anthonybaxter@gmail.com> | 2004-10-13 15:54:17 (GMT) |
commit | 22dcf66f849c50c8bcb08537c02e8242ae6a0f4a (patch) | |
tree | 9deca02f0530285ed09d01a7c87d6592770240cf /setup.py | |
parent | 8a560dee7291f75968eea773c1258f2c25b5a81f (diff) | |
download | cpython-22dcf66f849c50c8bcb08537c02e8242ae6a0f4a.zip cpython-22dcf66f849c50c8bcb08537c02e8242ae6a0f4a.tar.gz cpython-22dcf66f849c50c8bcb08537c02e8242ae6a0f4a.tar.bz2 |
Patch 983206: distutils obeys LDSHARED env var. Removed the code in
Python's own setup.py that did the same thing (and tested on Solaris,
where LDSHARED is needed...)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 0 insertions, 3 deletions
@@ -167,15 +167,12 @@ class PyBuildExt(build_ext): # those environment variables passed into the setup.py phase. Here's # a small set of useful ones. compiler = os.environ.get('CC') - linker_so = os.environ.get('LDSHARED') args = {} # unfortunately, distutils doesn't let us provide separate C and C++ # compilers if compiler is not None: (ccshared,opt,base) = sysconfig.get_config_vars('CCSHARED','OPT','BASECFLAGS') args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared + ' ' + base - if linker_so is not None: - args['linker_so'] = linker_so self.compiler.set_executables(**args) build_ext.build_extensions(self) |