diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2001-02-06 23:37:23 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2001-02-06 23:37:23 (GMT) |
commit | 3c044942ab7deb4d776861e3a0620ba924136e9a (patch) | |
tree | 64f1c82f881734689f05314208728f6af2a55bfe /setup.py | |
parent | 8820a535c19f947b6eaea8365e084bea64c53797 (diff) | |
download | cpython-3c044942ab7deb4d776861e3a0620ba924136e9a.zip cpython-3c044942ab7deb4d776861e3a0620ba924136e9a.tar.gz cpython-3c044942ab7deb4d776861e3a0620ba924136e9a.tar.bz2 |
BeOS doesn't have a libm.a, either; noted by Donn Cave
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -118,6 +118,8 @@ class PyBuildExt(build_ext): platform = sys.platform if platform[:6] =='cygwin': platform = 'cygwin' + elif platform[:4] =='beos': + platform = 'beos' return platform @@ -139,7 +141,7 @@ class PyBuildExt(build_ext): # Check for MacOS X, which doesn't need libm.a at all math_libs = ['m'] - if platform == 'Darwin1.2': + if platform in ['Darwin1.2', 'beos']: math_libs = [] # XXX Omitted modules: gl, pure, dl, SGI-specific modules |