summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2008-06-06 09:11:46 (GMT)
committerThomas Heller <theller@ctypes.org>2008-06-06 09:11:46 (GMT)
commit9af0cba7d1c321b28d2257f4c499631e09258e49 (patch)
tree013b990acff3a256ef3c40346e1d3cff51218362 /setup.py
parentc5e88d5f471056c14ae9d6677cef5473282936ad (diff)
downloadcpython-9af0cba7d1c321b28d2257f4c499631e09258e49.zip
cpython-9af0cba7d1c321b28d2257f4c499631e09258e49.tar.gz
cpython-9af0cba7d1c321b28d2257f4c499631e09258e49.tar.bz2
Merged revisions 63897-63898 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r63897 | thomas.heller | 2008-06-02 20:41:30 +0200 (Mon, 02 Jun 2008) | 1 line Fix misspelled sys.platform name and misspelled filename. ........ r63898 | thomas.heller | 2008-06-02 22:07:46 +0200 (Mon, 02 Jun 2008) | 1 line Fix the -x flag so that is does work. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4921ded..1c46305 100644
--- a/setup.py
+++ b/setup.py
@@ -1416,7 +1416,7 @@ class PyBuildExt(build_ext):
# finding some -z option for the Sun compiler.
extra_link_args.append('-mimpure-text')
- elif sys.platform.startswith('hpux'):
+ elif sys.platform.startswith('hp-ux'):
extra_link_args.append('-fPIC')
ext = Extension('_ctypes',