summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMarc-André Lemburg <mal@egenix.com>2002-12-12 17:37:50 (GMT)
committerMarc-André Lemburg <mal@egenix.com>2002-12-12 17:37:50 (GMT)
commitb28de0d79f6f1bfc7e395a1945167a87bfe95356 (patch)
tree2e4771db60c9a7d0a96b46144944565f30b728ee /setup.py
parentb69bb3d0193ea4871d2480a58e48224cb728e4d9 (diff)
downloadcpython-b28de0d79f6f1bfc7e395a1945167a87bfe95356.zip
cpython-b28de0d79f6f1bfc7e395a1945167a87bfe95356.tar.gz
cpython-b28de0d79f6f1bfc7e395a1945167a87bfe95356.tar.bz2
Patch to make _codecs a builtin module. This is necessary since
Python 2.3 will support source code encodings which rely on the builtin codecs being available to the parser. Remove struct dependency from codecs.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ff7318e..2827af7 100644
--- a/setup.py
+++ b/setup.py
@@ -313,8 +313,6 @@ class PyBuildExt(build_ext):
libraries=math_libs) )
# operator.add() and similar goodies
exts.append( Extension('operator', ['operator.c']) )
- # access to the builtin codecs and codec registry
- exts.append( Extension('_codecs', ['_codecsmodule.c']) )
# Python C API test module
exts.append( Extension('_testcapi', ['_testcapimodule.c']) )
# static Unicode character database