summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2005-04-25 07:14:03 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2005-04-25 07:14:03 (GMT)
commitd7c795e72966f7c72b94b919f3539be66495e6c3 (patch)
treea2cea19622186e95faeb32553e1635d185ad8d4c /setup.py
parent08cd598c2145d00f1517c93cabf80a5d7d2a4bc0 (diff)
downloadcpython-d7c795e72966f7c72b94b919f3539be66495e6c3.zip
cpython-d7c795e72966f7c72b94b919f3539be66495e6c3.tar.gz
cpython-d7c795e72966f7c72b94b919f3539be66495e6c3.tar.bz2
Make parse_makefile fallback to environment variables if nothing is
defined in the makefile. Get CFLAGS from the Makefile, instead of getting OPT, BASE_CFLAGS and EXTRA_CFLAGS individually.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 302f5c2..a8e5804 100644
--- a/setup.py
+++ b/setup.py
@@ -171,8 +171,8 @@ class PyBuildExt(build_ext):
# unfortunately, distutils doesn't let us provide separate C and C++
# compilers
if compiler is not None:
- (ccshared,opt,base) = sysconfig.get_config_vars('CCSHARED','OPT','BASECFLAGS')
- args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared + ' ' + base
+ (ccshared,cflags) = sysconfig.get_config_vars('CCSHARED','CFLAGS')
+ args['compiler_so'] = compiler + ' ' + ccshared + ' ' + cflags
self.compiler.set_executables(**args)
build_ext.build_extensions(self)