diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2001-12-06 15:57:16 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2001-12-06 15:57:16 (GMT) |
commit | e7ffbb24e80800de3667a88af96d03f8c9717039 (patch) | |
tree | b57c734a344c915d58b54857851e9e1152d6eb2c /setup.py | |
parent | 1a48ca8c53b80627ebf3c4215140cdc07152556d (diff) | |
download | cpython-e7ffbb24e80800de3667a88af96d03f8c9717039.zip cpython-e7ffbb24e80800de3667a88af96d03f8c9717039.tar.gz cpython-e7ffbb24e80800de3667a88af96d03f8c9717039.tar.bz2 |
[Bug #480882] Remove now-pointless check for existence for _curses_panel.c;
Bugfix candidate.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -472,8 +472,7 @@ class PyBuildExt(build_ext): libraries = curses_libs) ) # If the curses module is enabled, check for the panel module - if (os.path.exists('Modules/_curses_panel.c') and - module_enabled(exts, '_curses') and + if (module_enabled(exts, '_curses') and self.compiler.find_library_file(lib_dirs, 'panel')): exts.append( Extension('_curses_panel', ['_curses_panel.c'], libraries = ['panel'] + curses_libs) ) |