diff options
author | Benjamin Peterson <benjamin@python.org> | 2009-12-30 03:06:54 (GMT) |
---|---|---|
committer | Benjamin Peterson <benjamin@python.org> | 2009-12-30 03:06:54 (GMT) |
commit | f9a6dab7931db9118b6f3f93cb2c6bdc51679d23 (patch) | |
tree | 5117629242d24499b0c65e8a29994b6d1d827a17 /setup.py | |
parent | 54d74681db71dfc979450f261cc6cc3ace9be22c (diff) | |
download | cpython-f9a6dab7931db9118b6f3f93cb2c6bdc51679d23.zip cpython-f9a6dab7931db9118b6f3f93cb2c6bdc51679d23.tar.gz cpython-f9a6dab7931db9118b6f3f93cb2c6bdc51679d23.tar.bz2 |
Merged revisions 77129,77132 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k
................
r77129 | benjamin.peterson | 2009-12-29 21:02:03 -0600 (Tue, 29 Dec 2009) | 9 lines
Merged revisions 77128 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r77128 | benjamin.peterson | 2009-12-29 20:58:50 -0600 (Tue, 29 Dec 2009) | 1 line
only build the nis module when the headers are found #7589
........
................
r77132 | benjamin.peterson | 2009-12-29 21:03:54 -0600 (Tue, 29 Dec 2009) | 9 lines
Merged revisions 77130 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r77130 | benjamin.peterson | 2009-12-29 21:02:34 -0600 (Tue, 29 Dec 2009) | 1 line
wrap long line
........
................
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -979,8 +979,9 @@ class PyBuildExt(build_ext): missing.append('resource') # Sun yellow pages. Some systems have the functions in libc. - if platform not in ['cygwin', 'atheos', 'qnx6']: - if (self.compiler.find_library_file(lib_dirs, 'nsl')): + if (platform not in ['cygwin', 'qnx6'] and + find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None): + if (self.compiler_obj.find_library_file(lib_dirs, 'nsl')): libs = ['nsl'] else: libs = [] |