diff options
author | Marc-André Lemburg <mal@egenix.com> | 2001-01-26 18:23:02 (GMT) |
---|---|---|
committer | Marc-André Lemburg <mal@egenix.com> | 2001-01-26 18:23:02 (GMT) |
commit | 2efc3238d749977364568422eb0acec37c2438ba (patch) | |
tree | 2a2780f4bfe9164e24922b81ca30cd6b6864c17c /setup.py | |
parent | 7c6fcda7bfe45a3b075f6434ebb65055ab4d7537 (diff) | |
download | cpython-2efc3238d749977364568422eb0acec37c2438ba.zip cpython-2efc3238d749977364568422eb0acec37c2438ba.tar.gz cpython-2efc3238d749977364568422eb0acec37c2438ba.tar.bz2 |
Be extra careful with linking against libtermcap. This is now only done
if we can find the libtermcap in the usual places. Some platforms don't
have libtermcap, e.g. MacOSX.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -242,10 +242,15 @@ class PyBuildExt(build_ext): exts.append( Extension('rgbimg', ['rgbimgmodule.c']) ) # readline - if (self.compiler.find_library_file(lib_dirs, 'readline')): + if self.compiler.find_library_file(lib_dirs, 'readline'): + readline_libs = ['readline'] + if self.compiler.find_library_file(lib_dirs + + ['/usr/lib/termcap'], + 'termcap'): + readline_libs.append('termcap') exts.append( Extension('readline', ['readline.c'], library_dirs=['/usr/lib/termcap'], - libraries=['readline', 'termcap']) ) + libraries=readline_libs) ) # The crypt module is now disabled by default because it breaks builds # on many systems (where -lcrypt is needed), e.g. Linux (I believe). |