diff options
author | Martin v. Löwis <martin@v.loewis.de> | 2001-08-10 08:56:17 (GMT) |
---|---|---|
committer | Martin v. Löwis <martin@v.loewis.de> | 2001-08-10 08:56:17 (GMT) |
commit | 3e4b0e800b04380e669d4cff7f8c77bdc031b170 (patch) | |
tree | c582c6aa804d136ed28129321ceddeb6d94b4d48 /setup.py | |
parent | 772747b3f1f4d6a70c025a7368ed25f039ccff1d (diff) | |
download | cpython-3e4b0e800b04380e669d4cff7f8c77bdc031b170.zip cpython-3e4b0e800b04380e669d4cff7f8c77bdc031b170.tar.gz cpython-3e4b0e800b04380e669d4cff7f8c77bdc031b170.tar.bz2 |
Get OPT from the environment to build the CCSHARED command.
Fixes the problem reported in bug #438786.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -138,8 +138,8 @@ class PyBuildExt(build_ext): # unfortunately, distutils doesn't let us provide separate C and C++ # compilers if compiler is not None: - (ccshared,) = sysconfig.get_config_vars('CCSHARED') - args['compiler_so'] = compiler + ' ' + ccshared + (ccshared,opt) = sysconfig.get_config_vars('CCSHARED','OPT') + args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared if linker_so is not None: args['linker_so'] = linker_so + ' -shared' self.compiler.set_executables(**args) |