diff options
author | Antoine Pitrou <solipsis@pitrou.net> | 2010-09-07 14:58:50 (GMT) |
---|---|---|
committer | Antoine Pitrou <solipsis@pitrou.net> | 2010-09-07 14:58:50 (GMT) |
commit | 15db1443aeac81fc8587409ab9eafbbde8c093e1 (patch) | |
tree | 4c62302380824bc03b327a63840ed0a8e2ec997d /setup.py | |
parent | 496153952a86e8f1c2e3be139ff96c3cca02ef38 (diff) | |
download | cpython-15db1443aeac81fc8587409ab9eafbbde8c093e1.zip cpython-15db1443aeac81fc8587409ab9eafbbde8c093e1.tar.gz cpython-15db1443aeac81fc8587409ab9eafbbde8c093e1.tar.bz2 |
Merged revisions 84584 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k
........
r84584 | antoine.pitrou | 2010-09-07 16:52:42 +0200 (mar., 07 sept. 2010) | 4 lines
Issue #4026: Make the fcntl extension build under AIX.
Patch by Sébastien Sablé.
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -489,7 +489,11 @@ class PyBuildExt(build_ext): # supported...) # fcntl(2) and ioctl(2) - exts.append( Extension('fcntl', ['fcntlmodule.c']) ) + libs = [] + if (config_h_vars.get('FLOCK_NEEDS_LIBBSD', False)): + # May be necessary on AIX for flock function + libs = ['bsd'] + exts.append( Extension('fcntl', ['fcntlmodule.c'], libraries=libs) ) if platform not in ['mac']: # pwd(3) exts.append( Extension('pwd', ['pwdmodule.c']) ) |