summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2012-09-06 16:03:32 (GMT)
committerChristian Heimes <christian@cheimes.de>2012-09-06 16:03:32 (GMT)
commit6d1fb5aa85fd69099f1e7787d6c7b3c4b117de3a (patch)
treee5a02b8805fac11055b161ee73cc5b546fd0595b /setup.py
parentd9c1bf7f1f4d5436956c3629ed97cec507463951 (diff)
parent7dd06e1dc038ffb8c765a024910f24be21fb2c8f (diff)
downloadcpython-6d1fb5aa85fd69099f1e7787d6c7b3c4b117de3a.zip
cpython-6d1fb5aa85fd69099f1e7787d6c7b3c4b117de3a.tar.gz
cpython-6d1fb5aa85fd69099f1e7787d6c7b3c4b117de3a.tar.bz2
Issue #15591: run ctypes' configure in quiet mode when setup.py runs silently
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9ddf2e9..d60967a 100644
--- a/setup.py
+++ b/setup.py
@@ -1788,6 +1788,8 @@ class PyBuildExt(build_ext):
mkpath(ffi_builddir)
config_args = [arg for arg in sysconfig.get_config_var("CONFIG_ARGS").split()
if (('--host=' in arg) or ('--build=' in arg))]
+ if not self.verbose:
+ config_args.append("-q")
# Pass empty CFLAGS because we'll just append the resulting
# CFLAGS to Python's; -g or -O2 is to be avoided.