diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-10-20 13:40:38 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-10-20 13:40:38 (GMT) |
commit | 7e7dbab08a85937cd6a81acfc57dfff3b42dfbb6 (patch) | |
tree | 39599ac9c7997c0d6c8201a641d2f7dcd6faebd8 /setup.py | |
parent | 455b0db6ffbf27145940a7eb48adf38d61005ee7 (diff) | |
download | cpython-7e7dbab08a85937cd6a81acfc57dfff3b42dfbb6.zip cpython-7e7dbab08a85937cd6a81acfc57dfff3b42dfbb6.tar.gz cpython-7e7dbab08a85937cd6a81acfc57dfff3b42dfbb6.tar.bz2 |
Merged revisions 85744 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k
........
r85744 | ronald.oussoren | 2010-10-20 15:10:12 +0200 (Wed, 20 Oct 2010) | 7 lines
Fix for issue #7473.
Without this patch you'll get link errors in some extensions
(in particular the _curses_panel) one when you try to build
a 3-way universal framework when you previously installed a
2-way universal framework using the python.org installer.
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -378,7 +378,12 @@ class PyBuildExt(build_ext): for directory in reversed(options.dirs): add_dir_to_list(dir_list, directory) - if os.path.normpath(sys.prefix) != '/usr': + if os.path.normpath(sys.prefix) != '/usr' \ + and not sysconfig.get_config_var('PYTHONFRAMEWORK'): + # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework + # (PYTHONFRAMEWORK is set) to avoid # linking problems when + # building a framework with different architectures than + # the one that is currently installed (issue #7473) add_dir_to_list(self.compiler.library_dirs, sysconfig.get_config_var("LIBDIR")) add_dir_to_list(self.compiler.include_dirs, |