summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew MacIntyre <andymac@bullseye.apana.org.au>2005-03-09 22:21:08 (GMT)
committerAndrew MacIntyre <andymac@bullseye.apana.org.au>2005-03-09 22:21:08 (GMT)
commit953f98d4bdd27c74e2c4220b90e20f8e6e6c8b7f (patch)
treed034d1c28d75b2c40db974566635e522e2a8a6af /setup.py
parent984f9bb7140683fa9b950b42a035477108aba88f (diff)
downloadcpython-953f98d4bdd27c74e2c4220b90e20f8e6e6c8b7f.zip
cpython-953f98d4bdd27c74e2c4220b90e20f8e6e6c8b7f.tar.gz
cpython-953f98d4bdd27c74e2c4220b90e20f8e6e6c8b7f.tar.bz2
add support for another DB library naming convention (FreeBSD ports)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3411643a..b881f83 100644
--- a/setup.py
+++ b/setup.py
@@ -598,7 +598,9 @@ class PyBuildExt(build_ext):
# XXX should we -ever- look for a dbX name? Do any
# systems really not name their library by version and
# symlink to more general names?
- for dblib in (('db-%d.%d' % db_ver), ('db%d' % db_ver[0])):
+ for dblib in (('db-%d.%d' % db_ver),
+ ('db%d%d' % db_ver),
+ ('db%d' % db_ver[0])):
dblib_file = self.compiler.find_library_file(
db_dirs_to_check + lib_dirs, dblib )
if dblib_file: