diff options
author | Christian Heimes <christian@cheimes.de> | 2013-02-09 16:02:06 (GMT) |
---|---|---|
committer | Christian Heimes <christian@cheimes.de> | 2013-02-09 16:02:06 (GMT) |
commit | d489c7a0a3936cd4bbb746e6c3eac36bff38d74b (patch) | |
tree | 634bc1771b48d6751533deb234ffd544392da3b5 /setup.py | |
parent | bbbbe8eb600a9efa4c3a13ae49dcdcdbb051f22a (diff) | |
download | cpython-d489c7a0a3936cd4bbb746e6c3eac36bff38d74b.zip cpython-d489c7a0a3936cd4bbb746e6c3eac36bff38d74b.tar.gz cpython-d489c7a0a3936cd4bbb746e6c3eac36bff38d74b.tar.bz2 |
add proper dependencies on expat headers and sources
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 17 insertions, 1 deletions
@@ -1309,6 +1309,7 @@ class PyBuildExt(build_ext): define_macros = [] expat_lib = ['expat'] expat_sources = [] + expat_depends = [] else: expat_inc = [os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')] define_macros = [ @@ -1318,12 +1319,25 @@ class PyBuildExt(build_ext): expat_sources = ['expat/xmlparse.c', 'expat/xmlrole.c', 'expat/xmltok.c'] + expat_depends = ['expat/ascii.h', + 'expat/asciitab.h', + 'expat/expat.h', + 'expat/expat_config.h', + 'expat/expat_external.h', + 'expat/internal.h', + 'expat/latin1tab.h', + 'expat/utf8tab.h', + 'expat/xmlrole.h', + 'expat/xmltok.h', + 'expat/xmltok_impl.h' + ] exts.append(Extension('pyexpat', define_macros = define_macros, include_dirs = expat_inc, libraries = expat_lib, - sources = ['pyexpat.c'] + expat_sources + sources = ['pyexpat.c'] + expat_sources, + depends = expat_depends, )) # Fredrik Lundh's cElementTree module. Note that this also @@ -1336,6 +1350,8 @@ class PyBuildExt(build_ext): include_dirs = expat_inc, libraries = expat_lib, sources = ['_elementtree.c'], + depends = ['pyexpat.c'] + expat_sources + + expat_depends, )) else: missing.append('_elementtree') |