summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2008-07-16 02:39:02 (GMT)
committerBenjamin Peterson <benjamin@python.org>2008-07-16 02:39:02 (GMT)
commitfc576351c0dcfd419349ac6d6201c3ccd6338247 (patch)
treea928a77c60bb2e83ac139914d0f282de308d2fee /setup.py
parent8f95cc296553166f1b9b92600f65c3e4ec61152b (diff)
downloadcpython-fc576351c0dcfd419349ac6d6201c3ccd6338247.zip
cpython-fc576351c0dcfd419349ac6d6201c3ccd6338247.tar.gz
cpython-fc576351c0dcfd419349ac6d6201c3ccd6338247.tar.bz2
sys.maxint -> sys.maxsize
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0519bf7..90fe68f 100644
--- a/setup.py
+++ b/setup.py
@@ -243,7 +243,7 @@ class PyBuildExt(build_ext):
return
if self.get_platform() == 'darwin' and (
- sys.maxint > 2**32 and '-arch' in ext.extra_link_args):
+ sys.maxsize > 2**32 and '-arch' in ext.extra_link_args):
# Don't bother doing an import check when an extension was
# build with an explicit '-arch' flag on OSX. That's currently
# only used to build 32-bit only extensions in a 4-way