diff options
author | Ned Deily <nad@acm.org> | 2012-07-30 09:35:58 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2012-07-30 09:35:58 (GMT) |
commit | 2910a7ba6bac0e51c05a5405de1c858da73687b4 (patch) | |
tree | 3f07128f7ddcb7f61bfdf47db9659fc9bae28ad6 /setup.py | |
parent | 5d6aeb8d9968fff9a132947e8420105af6856d0c (diff) | |
download | cpython-2910a7ba6bac0e51c05a5405de1c858da73687b4.zip cpython-2910a7ba6bac0e51c05a5405de1c858da73687b4.tar.gz cpython-2910a7ba6bac0e51c05a5405de1c858da73687b4.tar.bz2 |
Issue #14018: Fix OS X Tcl/Tk framework checking when using OS X SDKs.
Also add tests in the OS X installer build to ensure that the desired
dynamic linking with an optional newer Tcl/Tk in /Library actually
happens.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -69,7 +69,9 @@ def is_macosx_sdk_path(path): """ Returns True if 'path' can be located in an OSX SDK """ - return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/') + return ( (path.startswith('/usr/') and not path.startswith('/usr/local')) + or path.startswith('/System/') + or path.startswith('/Library/') ) def find_file(filename, std_dirs, paths): """Searches for the directory where a given file is located, |