summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-02-28 22:49:26 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-02-28 22:49:26 (GMT)
commit3da989c6bc0c80bd75547dbd8efc5a9deb29eff5 (patch)
tree0ce76ab56bb17e4a6e3d5d1c99154c9199bad556 /setup.py
parent8bad993dd375fdcd87ebfa661ffefb91e7f0d89b (diff)
downloadcpython-3da989c6bc0c80bd75547dbd8efc5a9deb29eff5.zip
cpython-3da989c6bc0c80bd75547dbd8efc5a9deb29eff5.tar.gz
cpython-3da989c6bc0c80bd75547dbd8efc5a9deb29eff5.tar.bz2
Fix for bug #405007: prefix subdir to scripts in order to build in
a subdirectory.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 40e65d4..67bf5b7 100644
--- a/setup.py
+++ b/setup.py
@@ -79,6 +79,10 @@ class PyBuildExt(build_ext):
srcdir = os.path.normpath(srcdir)
moddir = os.path.normpath(moddir)
+ # Fix up the paths for scripts, too
+ self.distribution.scripts = [os.path.join(srcdir, filename)
+ for filename in self.distribution.scripts]
+
for ext in self.extensions[:]:
ext.sources = [ os.path.join(moddir, filename)
for filename in ext.sources ]