summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2012-09-30 19:12:53 (GMT)
committerStefan Krah <skrah@bytereef.org>2012-09-30 19:12:53 (GMT)
commitce23dbc1f092ec77ccaf740d2d2ca3ffa3c4d51d (patch)
tree35b73b32acfd40c0c84ac22ed45dfa06653da129 /setup.py
parent03074fd450e3e0dcfcee593d7e8309c3c5b1ff66 (diff)
downloadcpython-ce23dbc1f092ec77ccaf740d2d2ca3ffa3c4d51d.zip
cpython-ce23dbc1f092ec77ccaf740d2d2ca3ffa3c4d51d.tar.gz
cpython-ce23dbc1f092ec77ccaf740d2d2ca3ffa3c4d51d.tar.bz2
Suppress unknown pragma warning (STDC FENV_ACCESS).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d60967a..4dc58c8 100644
--- a/setup.py
+++ b/setup.py
@@ -1985,6 +1985,7 @@ class PyBuildExt(build_ext):
# solaris: problems with register allocation.
# icc >= 11.0 works as well.
define_macros = config['ppro']
+ extra_compile_args.append('-Wno-unknown-pragmas')
else:
define_macros = config['ansi32']
else: