diff options
author | Jason Tishler <jason@tishler.net> | 2003-02-05 15:16:17 (GMT) |
---|---|---|
committer | Jason Tishler <jason@tishler.net> | 2003-02-05 15:16:17 (GMT) |
commit | 9181c94e05250b8f69615a96634d55afe532e406 (patch) | |
tree | 95872c41969992fac16810ee1906234af3c07f8d /setup.py | |
parent | cccac1a163915d7a4e757a1a4e62b21c91b5c475 (diff) | |
download | cpython-9181c94e05250b8f69615a96634d55afe532e406.zip cpython-9181c94e05250b8f69615a96634d55afe532e406.tar.gz cpython-9181c94e05250b8f69615a96634d55afe532e406.tar.bz2 |
This patch reverts the following:
It also prevents building against the real X headers, if installed.
After discussions with the Cygwin project lead, I believe that building
against the real X headers is OK. Especially, since the psuedo-X headers
are *not* installed by the Cygwin Tcl/Tk binary package.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -953,11 +953,6 @@ class PyBuildExt(build_ext): if platform == 'sunos5': include_dirs.append('/usr/openwin/include') added_lib_dirs.append('/usr/openwin/lib') - elif platform == 'cygwin': - # Verify that the pseudo-X headers are installed before proceeding - x11_inc = find_file('X11/Xlib.h', [], inc_dirs) - if x11_inc is None: - return elif os.path.exists('/usr/X11R6/include'): include_dirs.append('/usr/X11R6/include') added_lib_dirs.append('/usr/X11R6/lib') @@ -969,6 +964,12 @@ class PyBuildExt(build_ext): include_dirs.append('/usr/X11/include') added_lib_dirs.append('/usr/X11/lib') + # If Cygwin, then verify that X is installed before proceeding + if platform == 'cygwin': + x11_inc = find_file('X11/Xlib.h', [], include_dirs) + if x11_inc is None: + return + # Check for BLT extension if self.compiler.find_library_file(lib_dirs + added_lib_dirs, 'BLT8.0'): |