summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@haypocalc.com>2011-11-28 23:08:12 (GMT)
committerVictor Stinner <victor.stinner@haypocalc.com>2011-11-28 23:08:12 (GMT)
commitaa35b0032235b6b935da0f08f79bba7296ced5fc (patch)
treee2265d65fbc310ddff3d07d1fca1fcd669874a64 /setup.py
parent5d7c9aba29ee73ce5708f97beb1371222cc5889e (diff)
downloadcpython-aa35b0032235b6b935da0f08f79bba7296ced5fc.zip
cpython-aa35b0032235b6b935da0f08f79bba7296ced5fc.tar.gz
cpython-aa35b0032235b6b935da0f08f79bba7296ced5fc.tar.bz2
cleanup setup.py for curses options
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 8 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 1e450c7..fff4361 100644
--- a/setup.py
+++ b/setup.py
@@ -1166,20 +1166,19 @@ class PyBuildExt(build_ext):
else:
missing.extend(['nis', 'resource', 'termios'])
+ # Curses support, requiring the System V version of curses, often
+ # provided by the ncurses library.
curses_defines = []
+ curses_includes = []
+ panel_library = 'panel'
if curses_library == 'ncursesw':
curses_defines.append(('HAVE_NCURSESW', '1'))
+ curses_includes.append('/usr/include/ncursesw')
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.
+ panel_library = 'panelw'
- # Curses support, requiring the System V version of curses, often
- # provided by the ncurses library.
- panel_library = 'panel'
- curses_includes = []
if curses_library.startswith('ncurses'):
- if curses_library == 'ncursesw':
- # Bug 1464056: If _curses.so links with ncursesw,
- # _curses_panel.so must link with panelw.
- panel_library = 'panelw'
- curses_includes = ['/usr/include/ncursesw']
curses_libs = [curses_library]
exts.append( Extension('_curses', ['_cursesmodule.c'],
include_dirs=curses_includes,