diff options
author | Jason Tishler <jason@tishler.net> | 2003-02-05 15:06:46 (GMT) |
---|---|---|
committer | Jason Tishler <jason@tishler.net> | 2003-02-05 15:06:46 (GMT) |
commit | cccac1a163915d7a4e757a1a4e62b21c91b5c475 (patch) | |
tree | 698d7f2c7ac900a5d8c7f2ce9acdc193961e8bcd /setup.py | |
parent | 769e1ff4a134cce66f4bd8ead4c56668ec6bfe30 (diff) | |
download | cpython-cccac1a163915d7a4e757a1a4e62b21c91b5c475.zip cpython-cccac1a163915d7a4e757a1a4e62b21c91b5c475.tar.gz cpython-cccac1a163915d7a4e757a1a4e62b21c91b5c475.tar.bz2 |
This patch enables Cygwin Python to build _tkinter against Tcl/Tk 8.4.
Note that this patch just reverts the lib_prefix (i.e., "cyg") portion
of my Tcl/Tk 8.3 patch. It seems that Cygwin Tcl/Tk is using a more
normal file naming convention again.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 4 insertions, 12 deletions
@@ -915,22 +915,14 @@ class PyBuildExt(build_ext): self.detect_tkinter_darwin(inc_dirs, lib_dirs): return - # Set platform specific library prefix, if any - if platform == 'cygwin': - lib_prefix = 'cyg' - else: - lib_prefix = '' - # Assume we haven't found any of the libraries or include files # The versions with dots are used on Unix, and the versions without # dots on Windows, for detection by cygwin. tcllib = tklib = tcl_includes = tk_includes = None for version in ['8.4', '84', '8.3', '83', '8.2', '82', '8.1', '81', '8.0', '80']: - tklib = self.compiler.find_library_file(lib_dirs, - lib_prefix + 'tk' + version) - tcllib = self.compiler.find_library_file(lib_dirs, - lib_prefix + 'tcl' + version) + tklib = self.compiler.find_library_file(lib_dirs, 'tk' + version) + tcllib = self.compiler.find_library_file(lib_dirs, 'tcl' + version) if tklib and tcllib: # Exit the loop when we've found the Tcl/Tk libraries break @@ -988,8 +980,8 @@ class PyBuildExt(build_ext): libs.append('BLT') # Add the Tcl/Tk libraries - libs.append(lib_prefix + 'tk'+ version) - libs.append(lib_prefix + 'tcl'+ version) + libs.append('tk'+ version) + libs.append('tcl'+ version) if platform in ['aix3', 'aix4']: libs.append('ld') |