diff options
author | Mark Dickinson <dickinsm@gmail.com> | 2009-12-21 15:27:41 (GMT) |
---|---|---|
committer | Mark Dickinson <dickinsm@gmail.com> | 2009-12-21 15:27:41 (GMT) |
commit | f371859a4f0705062e94798e21ebe3705d891a37 (patch) | |
tree | c4b520a35156bd0d6729980b1253a4ce04bf39c3 /setup.py | |
parent | 0f72d6c25fb3ff16b4c459221d56f87f221c59d0 (diff) | |
download | cpython-f371859a4f0705062e94798e21ebe3705d891a37.zip cpython-f371859a4f0705062e94798e21ebe3705d891a37.tar.gz cpython-f371859a4f0705062e94798e21ebe3705d891a37.tar.bz2 |
Merged revisions 76978 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r76978 | mark.dickinson | 2009-12-21 15:22:00 +0000 (Mon, 21 Dec 2009) | 3 lines
Issue #7518: Move substitute definitions of C99 math functions from
pymath.c to Modules/_math.c.
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -394,9 +394,9 @@ class PyBuildExt(build_ext): # array objects exts.append( Extension('array', ['arraymodule.c']) ) # complex math library functions - exts.append( Extension('cmath', ['cmathmodule.c'], + exts.append( Extension('cmath', ['cmathmodule.c', '_math.c'], + depends=['_math.h'], libraries=math_libs) ) - # math library functions, e.g. sin() exts.append( Extension('math', ['mathmodule.c', '_math.c'], depends=['_math.h'], |