summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2013-03-28 21:24:43 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2013-03-28 21:24:43 (GMT)
commit2463e5fee48b116a5f15cf703abe30e08ce114ca (patch)
tree17224b1adc4440741f050658a0b1615b23b80319 /setup.py
parentf2c64ed9eb649e83e6c6d7e16ab1752f97ef7fa6 (diff)
downloadcpython-2463e5fee48b116a5f15cf703abe30e08ce114ca.zip
cpython-2463e5fee48b116a5f15cf703abe30e08ce114ca.tar.gz
cpython-2463e5fee48b116a5f15cf703abe30e08ce114ca.tar.bz2
Issue #16692: The ssl module now supports TLS 1.1 and TLS 1.2. Initial patch by Michele OrrĂ¹.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 020772b..e6f3b53 100644
--- a/setup.py
+++ b/setup.py
@@ -786,10 +786,10 @@ class PyBuildExt(build_ext):
for line in incfile:
m = openssl_ver_re.match(line)
if m:
- openssl_ver = eval(m.group(1))
+ openssl_ver = int(m.group(1), 16)
+ break
except IOError as msg:
print("IOError while reading opensshv.h:", msg)
- pass
#print('openssl_ver = 0x%08x' % openssl_ver)
min_openssl_ver = 0x00907000