summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2014-01-03 13:05:06 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2014-01-03 13:05:06 (GMT)
commit24e43308b7e40c09717c1ab99014710fa5a01735 (patch)
treeb2a1198fbbb3e38ff6232785d474d6a0354a2648 /setup.py
parentf3b46b4a66560945d4c80ac2f10764e3d7f71f8d (diff)
downloadcpython-24e43308b7e40c09717c1ab99014710fa5a01735.zip
cpython-24e43308b7e40c09717c1ab99014710fa5a01735.tar.gz
cpython-24e43308b7e40c09717c1ab99014710fa5a01735.tar.bz2
* Issue #16113: Remove sha3 module again.
Patch by Christian Heimes, with modifications.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index d7f52af..102d4ea 100644
--- a/setup.py
+++ b/setup.py
@@ -827,15 +827,6 @@ class PyBuildExt(build_ext):
exts.append( Extension('_sha1', ['sha1module.c'],
depends=['hashlib.h']) )
- # SHA-3 (Keccak) module
- sha3_depends = ['hashlib.h']
- keccak = os.path.join(os.getcwd(), srcdir, 'Modules', '_sha3',
- 'keccak')
- for pattern in ('*.c', '*.h', '*.macros'):
- sha3_depends.extend(glob(os.path.join(keccak, pattern)))
- exts.append(Extension("_sha3", ["_sha3/sha3module.c"],
- depends=sha3_depends))
-
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
# your machine, though none are defined by default because of library