diff options
author | Neil Schemenauer <nascheme@enme.ucalgary.ca> | 2009-02-06 00:27:50 (GMT) |
---|---|---|
committer | Neil Schemenauer <nascheme@enme.ucalgary.ca> | 2009-02-06 00:27:50 (GMT) |
commit | 4d491a535ccab3caef1dba0d079c398b551c045c (patch) | |
tree | 596d7e3e704bd6a3fdd62500ba847715e375146a /setup.py | |
parent | 6411aa5dd429acf4cd8f41c8e798d3df364d469a (diff) | |
download | cpython-4d491a535ccab3caef1dba0d079c398b551c045c.zip cpython-4d491a535ccab3caef1dba0d079c398b551c045c.tar.gz cpython-4d491a535ccab3caef1dba0d079c398b551c045c.tar.bz2 |
Distutils apparently requires an absolute path so provide one.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -117,7 +117,7 @@ class PyBuildExt(build_ext): if not srcdir: # Maybe running on Windows but not using CYGWIN? raise ValueError("No source directory; cannot proceed.") - srcdir = os.path.normpath(srcdir) + srcdir = os.path.abspath(srcdir) moddirlist = [os.path.join(srcdir, 'Modules')] # Platform-dependent module source and include directories |