summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2007-02-10 22:53:17 (GMT)
committerGuido van Rossum <guido@python.org>2007-02-10 22:53:17 (GMT)
commit4e66dfcdc495218ad5f98b12ad6b4b2b05630ab0 (patch)
treebfa5f03b8291499f7f4d9547c29d3d5f4fe35ec5 /setup.py
parent3ac6741f7922b7fdf05f9ba231c6eeff73580f8a (diff)
downloadcpython-4e66dfcdc495218ad5f98b12ad6b4b2b05630ab0.zip
cpython-4e66dfcdc495218ad5f98b12ad6b4b2b05630ab0.tar.gz
cpython-4e66dfcdc495218ad5f98b12ad6b4b2b05630ab0.tar.bz2
Random change to make this work unchanged when dict.keys() returns a dict view.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index aa087a9..3bd9d35 100644
--- a/setup.py
+++ b/setup.py
@@ -688,8 +688,7 @@ class PyBuildExt(build_ext):
# ignore this header, it didn't contain a version number
if db_setup_debug: print("db.h: unsupported version", db_ver, "in", d)
- db_found_vers = db_ver_inc_map.keys()
- db_found_vers.sort()
+ db_found_vers = sorted(db_ver_inc_map.keys())
while db_found_vers:
db_ver = db_found_vers.pop()