summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJesus Cea <jcea@jcea.es>2008-08-31 14:12:11 (GMT)
committerJesus Cea <jcea@jcea.es>2008-08-31 14:12:11 (GMT)
commit6ba3329c274e2c7876c61f2e98d4592310d26bae (patch)
tree6bb346e892269279fa2011c3e4bd4648b273a7ae /setup.py
parent73c96dbf34c70bbf1ef807b98d51cf9c0e9dc042 (diff)
downloadcpython-6ba3329c274e2c7876c61f2e98d4592310d26bae.zip
cpython-6ba3329c274e2c7876c61f2e98d4592310d26bae.tar.gz
cpython-6ba3329c274e2c7876c61f2e98d4592310d26bae.tar.bz2
bsddb code updated to version 4.7.3pre2. This code is the same than
Python 2.6 one, since the intention is to keep an unified 2.x/3.x codebase. The Python code is automatically translated using "2to3". Please, do not update this code in Python 3.0 by hand. Update the 2.6 one and then do "2to3".
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index f0fed72..69f7606 100644
--- a/setup.py
+++ b/setup.py
@@ -673,12 +673,8 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 5) # XXX(gregory.p.smith): 4.6 "works" but seems to
- # have issues on many platforms. I've temporarily
- # disabled 4.6 to see what the odd platform
- # buildbots say.
- max_db_ver = (4, 7) # XXX(matthias.klose): test with 4.7 on some buildds
- min_db_ver = (3, 3)
+ max_db_ver = (4, 7)
+ min_db_ver = (4, 0)
db_setup_debug = False # verbose debug prints from this script?
# construct a list of paths to look for the header file in on