summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-09-18 20:32:13 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-09-18 20:32:13 (GMT)
commit89fb72dd76e0ba32c919671cdddb500bbc4e2f0a (patch)
tree2fc32187aebd8e96a4578a0b7038804d02a55ea4 /setup.py
parent97c56357b19c516f1c2f8b824eefd15d5b5ef245 (diff)
downloadcpython-89fb72dd76e0ba32c919671cdddb500bbc4e2f0a.zip
cpython-89fb72dd76e0ba32c919671cdddb500bbc4e2f0a.tar.gz
cpython-89fb72dd76e0ba32c919671cdddb500bbc4e2f0a.tar.bz2
[Patch #462258] On Cygwin, don't build Tkinter unless the X header files
can be found.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9cb43ef..bb4be3f 100644
--- a/setup.py
+++ b/setup.py
@@ -653,6 +653,13 @@ class PyBuildExt(build_ext):
include_dirs.append('/usr/X11/include')
added_lib_dirs.append('/usr/X11/lib')
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], inc_dirs)
+ if x11_inc is None:
+ # X header files missing, so give up
+ return
+
# Check for BLT extension
if self.compiler.find_library_file(lib_dirs + added_lib_dirs, 'BLT8.0'):
defs.append( ('WITH_BLT', 1) )