diff options
author | Antoine Pitrou <pitrou@free.fr> | 2018-01-15 23:27:16 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-01-15 23:27:16 (GMT) |
commit | 94e1696d04c65e19ea52e5c8664079c9d9aa0e54 (patch) | |
tree | 2e68e71052365395b8fc843f30c9e430c0788ae6 /setup.py | |
parent | 5ec0feeeecc1617987ec6cdc6d62b916e718a5cf (diff) | |
download | cpython-94e1696d04c65e19ea52e5c8664079c9d9aa0e54.zip cpython-94e1696d04c65e19ea52e5c8664079c9d9aa0e54.tar.gz cpython-94e1696d04c65e19ea52e5c8664079c9d9aa0e54.tar.bz2 |
bpo-14976: Reentrant simple queue (#3346)
Add a queue.SimpleQueue class, an unbounded FIFO queue with a reentrant C implementation of put().
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -699,6 +699,8 @@ class PyBuildExt(build_ext): exts.append( Extension('_opcode', ['_opcode.c']) ) # asyncio speedups exts.append( Extension("_asyncio", ["_asynciomodule.c"]) ) + # _queue module + exts.append( Extension("_queue", ["_queuemodule.c"]) ) # Modules with some UNIX dependencies -- on by default: # (If you have a really backward UNIX, select and socket may not be |