summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-12-30 03:02:03 (GMT)
committerBenjamin Peterson <benjamin@python.org>2009-12-30 03:02:03 (GMT)
commite57d6766630c711a3bdba26a00cfc92827733ff5 (patch)
treea032f516c4e08715ecf25151520c197ec598c0c6 /setup.py
parentca5f1a716e386d600d58456afcd23f788b241c7f (diff)
downloadcpython-e57d6766630c711a3bdba26a00cfc92827733ff5.zip
cpython-e57d6766630c711a3bdba26a00cfc92827733ff5.tar.gz
cpython-e57d6766630c711a3bdba26a00cfc92827733ff5.tar.bz2
Merged revisions 77128 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r77128 | benjamin.peterson | 2009-12-29 20:58:50 -0600 (Tue, 29 Dec 2009) | 1 line only build the nis module when the headers are found #7589 ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9ea4e67..04305de 100644
--- a/setup.py
+++ b/setup.py
@@ -972,7 +972,7 @@ class PyBuildExt(build_ext):
exts.append( Extension('resource', ['resource.c']) )
# Sun yellow pages. Some systems have the functions in libc.
- if platform not in ['cygwin', 'qnx6']:
+ if platform not in ['cygwin', 'qnx6'] and find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None:
if (self.compiler_obj.find_library_file(lib_dirs, 'nsl')):
libs = ['nsl']
else: