summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrett Cannon <brett@python.org>2014-05-30 18:55:29 (GMT)
committerBrett Cannon <brett@python.org>2014-05-30 18:55:29 (GMT)
commit2a17bde930af72995a217f6625d763e828bf5ce1 (patch)
treee36ddef450d49c50b324d5e2741161f9ea22188c /setup.py
parentc8f0d6ebfc8e114d72c9e642ed33ebb93276427d (diff)
downloadcpython-2a17bde930af72995a217f6625d763e828bf5ce1.zip
cpython-2a17bde930af72995a217f6625d763e828bf5ce1.tar.gz
cpython-2a17bde930af72995a217f6625d763e828bf5ce1.tar.bz2
Issue #20383: Introduce importlib.util.module_from_spec().
Along the way, dismantle importlib._bootstrap._SpecMethods as it was no longer relevant and constructing the new function required partially dismantling the class anyway.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e6b4d51..ef8d0f8 100644
--- a/setup.py
+++ b/setup.py
@@ -342,7 +342,7 @@ class PyBuildExt(build_ext):
spec = importlib.util.spec_from_file_location(ext.name, ext_filename,
loader=loader)
try:
- importlib._bootstrap._SpecMethods(spec).load()
+ importlib._bootstrap._load(spec)
except ImportError as why:
self.failed_on_import.append(ext.name)
self.announce('*** WARNING: renaming "%s" since importing it'