summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-10-08 13:18:37 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2001-10-08 13:18:37 (GMT)
commit2f20dab9c1f2e123b7d8cc17393d0504825d439a (patch)
tree0c9d09cec9cc0cab254587b92f9f0294451ac7fa /setup.py
parent8158b5ad091d246748708794fba40dda724523b6 (diff)
downloadcpython-2f20dab9c1f2e123b7d8cc17393d0504825d439a.zip
cpython-2f20dab9c1f2e123b7d8cc17393d0504825d439a.tar.gz
cpython-2f20dab9c1f2e123b7d8cc17393d0504825d439a.tar.bz2
Do not add -shared to linker_so. Any necessary options should already be
in LDSHARED.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 36d63d2..30c6852 100644
--- a/setup.py
+++ b/setup.py
@@ -141,10 +141,7 @@ class PyBuildExt(build_ext):
(ccshared,opt) = sysconfig.get_config_vars('CCSHARED','OPT')
args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared
if linker_so is not None:
- if platform == 'darwin1':
- args['linker_so'] = linker_so
- else:
- args['linker_so'] = linker_so + ' -shared'
+ args['linker_so'] = linker_so
self.compiler.set_executables(**args)
build_ext.build_extensions(self)