diff options
author | Christian Heimes <christian@python.org> | 2016-09-06 20:35:14 (GMT) |
---|---|---|
committer | Christian Heimes <christian@python.org> | 2016-09-06 20:35:14 (GMT) |
commit | 3c397e4c39430000348f2f64d9e394bf1b61c509 (patch) | |
tree | b516d2790839d7068d77079c5e4c59fafcd8e232 /setup.py | |
parent | b9d9eeda2ad0155c2bb1ce6601f5b311d411f848 (diff) | |
download | cpython-3c397e4c39430000348f2f64d9e394bf1b61c509.zip cpython-3c397e4c39430000348f2f64d9e394bf1b61c509.tar.gz cpython-3c397e4c39430000348f2f64d9e394bf1b61c509.tar.bz2 |
Fix out-of-tree builds for blake2
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -889,8 +889,8 @@ class PyBuildExt(build_ext): exts.append( Extension('_sha1', ['sha1module.c'], depends=['hashlib.h']) ) - blake2_deps = [os.path.join('_blake2', 'impl', name) - for name in os.listdir('Modules/_blake2/impl')] + blake2_deps = glob(os.path.join(os.getcwd(), srcdir, + 'Modules/_blake2/impl/*')) blake2_deps.append('hashlib.h') blake2_macros = [] |