summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNick Coghlan <ncoghlan@gmail.com>2012-06-17 08:27:11 (GMT)
committerNick Coghlan <ncoghlan@gmail.com>2012-06-17 08:27:11 (GMT)
commit50f147a9be10ee379c4c7bacb81df5e4edf24044 (patch)
tree6a05d27dc1b9b6d8218631b15c0e9421cef64b25 /setup.py
parent02653f1b111c8b9f64de8960d9a55d4f5821e257 (diff)
downloadcpython-50f147a9be10ee379c4c7bacb81df5e4edf24044.zip
cpython-50f147a9be10ee379c4c7bacb81df5e4edf24044.tar.gz
cpython-50f147a9be10ee379c4c7bacb81df5e4edf24044.tar.bz2
Issue #15044: Handle Fedora 17's approach to ndbm compatibility
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b2829ac..2539f50 100644
--- a/setup.py
+++ b/setup.py
@@ -1077,10 +1077,14 @@ class PyBuildExt(build_ext):
for cand in dbm_order:
if cand == "ndbm":
if find_file("ndbm.h", inc_dirs, []) is not None:
- # Some systems have -lndbm, others don't
+ # Some systems have -lndbm, others have -lgdbm_compat,
+ # others don't have either
if self.compiler.find_library_file(lib_dirs,
'ndbm'):
ndbm_libs = ['ndbm']
+ elif self.compiler.find_library_file(lib_dirs,
+ 'gdbm_compat'):
+ ndbm_libs = ['gdbm_compat']
else:
ndbm_libs = []
print("building dbm using ndbm")