summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2012-04-12 17:09:00 (GMT)
committerCharles-François Natali <neologix@free.fr>2012-04-12 17:09:00 (GMT)
commit515ea9bd6568b737c062d9c166bb4c65420bb80a (patch)
treed1ba5503d3aaff4930a39b5051ae48aa3a7686f3 /setup.py
parent80a133b91c857f6da41c6eba3b6992af6d696347 (diff)
parent5739e102ddf62667167da7da878938d64896733d (diff)
downloadcpython-515ea9bd6568b737c062d9c166bb4c65420bb80a.zip
cpython-515ea9bd6568b737c062d9c166bb4c65420bb80a.tar.gz
cpython-515ea9bd6568b737c062d9c166bb4c65420bb80a.tar.bz2
Issue #14557: Fix extensions build on HP-UX. Patch by Adi Roiban.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fb8c4b6..8c6131c 100644
--- a/setup.py
+++ b/setup.py
@@ -464,6 +464,10 @@ class PyBuildExt(build_ext):
if platform in ['osf1', 'unixware7', 'openunix8']:
lib_dirs += ['/usr/ccs/lib']
+ # HP-UX11iv3 keeps files in lib/hpux folders.
+ if platform == 'hp-ux11':
+ lib_dirs += ['/usr/lib/hpux64', '/usr/lib/hpux32']
+
if platform == 'darwin':
# This should work on any unixy platform ;-)
# If the user has bothered specifying additional -I and -L flags