summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2010-08-08 18:24:06 (GMT)
committerThomas Heller <theller@ctypes.org>2010-08-08 18:24:06 (GMT)
commit51d19cf22798a34285eb78426eb349354fca4320 (patch)
treecd4374b69e05caf596e58e2eae8a59780ae55cb0 /setup.py
parent818afb55c9da56f370112e0b04dad66b8e067710 (diff)
downloadcpython-51d19cf22798a34285eb78426eb349354fca4320.zip
cpython-51d19cf22798a34285eb78426eb349354fca4320.tar.gz
cpython-51d19cf22798a34285eb78426eb349354fca4320.tar.bz2
Merged revisions 83837,83841 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r83837 | thomas.heller | 2010-08-08 19:58:53 +0200 (So, 08 Aug 2010) | 3 lines Fix issue5504: ctypes does now work with systems where mmap can't be PROT_WRITE and PROT_EXEC. ........ r83841 | thomas.heller | 2010-08-08 20:16:20 +0200 (So, 08 Aug 2010) | 2 lines Fix issue6869: refcount problem in the _ctypes extension. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 332033d..3cfd275 100644
--- a/setup.py
+++ b/setup.py
@@ -1636,8 +1636,7 @@ class PyBuildExt(build_ext):
'_ctypes/callbacks.c',
'_ctypes/callproc.c',
'_ctypes/stgdict.c',
- '_ctypes/cfield.c',
- '_ctypes/malloc_closure.c']
+ '_ctypes/cfield.c']
depends = ['_ctypes/ctypes.h']
if sys.platform == 'darwin':