summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2019-08-23 22:39:27 (GMT)
committerRaymond Hettinger <rhettinger@users.noreply.github.com>2019-08-23 22:39:27 (GMT)
commit5779c536321e1405b4c17654a85b8f9221be765e (patch)
tree48a9f516712595f455c6edf603bfbaa93eecebee /setup.py
parentaf84a88ef8b3288da528d2f52b7d3fbafb8dc8a6 (diff)
downloadcpython-5779c536321e1405b4c17654a85b8f9221be765e.zip
cpython-5779c536321e1405b4c17654a85b8f9221be765e.tar.gz
cpython-5779c536321e1405b4c17654a85b8f9221be765e.tar.bz2
bpo-37798: Add C fastpath for statistics.NormalDist.inv_cdf() (GH-15266) (GH-15441)
(cherry picked from commit 0a18ee4be7ba215f414bef04598e0849504f9f1e) Co-authored-by: Dong-hee Na <donghee.na92@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6cbbec9..be2ac0b 100644
--- a/setup.py
+++ b/setup.py
@@ -784,6 +784,8 @@ class PyBuildExt(build_ext):
self.add(Extension("_abc", ["_abc.c"]))
# _queue module
self.add(Extension("_queue", ["_queuemodule.c"]))
+ # _statistics module
+ self.add(Extension("_statistics", ["_statisticsmodule.c"]))
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be