summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2010-01-03 14:51:13 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2010-01-03 14:51:13 (GMT)
commit5af7fba6c7305151592348089f9943bd5e9cbe14 (patch)
treef16c69a1645c1e3fdd47c33e04566c154a47f97a /setup.py
parent5812bdf0981b3ba73accd544b8dd8f495c0a5ea3 (diff)
downloadcpython-5af7fba6c7305151592348089f9943bd5e9cbe14.zip
cpython-5af7fba6c7305151592348089f9943bd5e9cbe14.tar.gz
cpython-5af7fba6c7305151592348089f9943bd5e9cbe14.tar.bz2
add missing hashlib.h deps.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 9 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index d948770..c1397d7 100644
--- a/setup.py
+++ b/setup.py
@@ -606,6 +606,7 @@ class PyBuildExt(build_ext):
# The _hashlib module wraps optimized implementations
# of hash functions from the OpenSSL library.
exts.append( Extension('_hashlib', ['_hashopenssl.c'],
+ depends = ['hashlib.h'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,
libraries = ['ssl', 'crypto']) )
@@ -617,13 +618,17 @@ class PyBuildExt(build_ext):
min_sha2_openssl_ver = 0x00908000
if COMPILED_WITH_PYDEBUG or openssl_ver < min_sha2_openssl_ver:
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
- exts.append( Extension('_sha256', ['sha256module.c']) )
- exts.append( Extension('_sha512', ['sha512module.c']) )
+ exts.append( Extension('_sha256', ['sha256module.c'],
+ depends=['hashlib.h']) )
+ exts.append( Extension('_sha512', ['sha512module.c'],
+ depends=['hashlib.h']) )
if COMPILED_WITH_PYDEBUG or not have_usable_openssl:
# no openssl at all, use our own md5 and sha1
- exts.append( Extension('_md5', ['md5module.c']) )
- exts.append( Extension('_sha1', ['sha1module.c']) )
+ exts.append( Extension('_md5', ['md5module.c'],
+ depends=['hashlib.h']) )
+ exts.append( Extension('_sha1', ['sha1module.c'],
+ depends=['hashlib.h']) )
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on