summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2008-09-03 23:30:49 (GMT)
committerBenjamin Peterson <benjamin@python.org>2008-09-03 23:30:49 (GMT)
commit6ecc5c19802b994b3b7033953361f6157b4bdd0d (patch)
tree033d2cfca91bd27e456ca69d5433eea1b93ef89a /setup.py
parent6ba2332f55e1d4dc49470cfc68fcedb3b6d096f8 (diff)
downloadcpython-6ecc5c19802b994b3b7033953361f6157b4bdd0d.zip
cpython-6ecc5c19802b994b3b7033953361f6157b4bdd0d.tar.gz
cpython-6ecc5c19802b994b3b7033953361f6157b4bdd0d.tar.bz2
db_incs is needed
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f411c5f..7837c8a 100644
--- a/setup.py
+++ b/setup.py
@@ -665,6 +665,20 @@ class PyBuildExt(build_ext):
# implementation independent wrapper for these; dbm/dumb.py provides
# similar functionality (but slower of course) implemented in Python.
+ db_inc_paths = [
+ '/usr/include/db4',
+ '/usr/local/include/db4',
+ '/opt/sfw/include/db4',
+ '/usr/include/db3',
+ '/usr/local/include/db3',
+ '/opt/sfw/include/db3',
+ # Fink defaults (http://fink.sourceforge.net/)
+ '/sw/include/db4',
+ '/sw/include/db3',
+ ]
+
+ db_incs = None
+
# The sqlite interface
sqlite_setup_debug = False # verbose debug prints from this script?