summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-02-09 16:02:16 (GMT)
committerChristian Heimes <christian@cheimes.de>2013-02-09 16:02:16 (GMT)
commit7d01a1eb2b636891fcac90f48290293bc2b9f3eb (patch)
tree0237a258ac775c20a8433637c93d7191026fa0cd /setup.py
parent5d50adee50daf843f160881a6c6421ca3833a09b (diff)
parentd489c7a0a3936cd4bbb746e6c3eac36bff38d74b (diff)
downloadcpython-7d01a1eb2b636891fcac90f48290293bc2b9f3eb.zip
cpython-7d01a1eb2b636891fcac90f48290293bc2b9f3eb.tar.gz
cpython-7d01a1eb2b636891fcac90f48290293bc2b9f3eb.tar.bz2
add proper dependencies on expat headers and sources
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 17 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4d69326..57dabc1 100644
--- a/setup.py
+++ b/setup.py
@@ -1394,6 +1394,7 @@ class PyBuildExt(build_ext):
define_macros = []
expat_lib = ['expat']
expat_sources = []
+ expat_depends = []
else:
expat_inc = [os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')]
define_macros = [
@@ -1403,12 +1404,25 @@ class PyBuildExt(build_ext):
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']
+ expat_depends = ['expat/ascii.h',
+ 'expat/asciitab.h',
+ 'expat/expat.h',
+ 'expat/expat_config.h',
+ 'expat/expat_external.h',
+ 'expat/internal.h',
+ 'expat/latin1tab.h',
+ 'expat/utf8tab.h',
+ 'expat/xmlrole.h',
+ 'expat/xmltok.h',
+ 'expat/xmltok_impl.h'
+ ]
exts.append(Extension('pyexpat',
define_macros = define_macros,
include_dirs = expat_inc,
libraries = expat_lib,
- sources = ['pyexpat.c'] + expat_sources
+ sources = ['pyexpat.c'] + expat_sources,
+ depends = expat_depends,
))
# Fredrik Lundh's cElementTree module. Note that this also
@@ -1421,6 +1435,8 @@ class PyBuildExt(build_ext):
include_dirs = expat_inc,
libraries = expat_lib,
sources = ['_elementtree.c'],
+ depends = ['pyexpat.c'] + expat_sources +
+ expat_depends,
))
else:
missing.append('_elementtree')