diff options
author | Anthony Sottile <asottile@umich.edu> | 2019-02-25 22:32:27 (GMT) |
---|---|---|
committer | Giampaolo Rodola <g.rodola@gmail.com> | 2019-02-25 22:32:27 (GMT) |
commit | 8377cd4fcd0d51d86834c9b0518d29aac3b49e18 (patch) | |
tree | e8d82c3567b2d39ff0bd285d25ce2d02359ae070 /setup.py | |
parent | 9c3f284de598550be6687964c23fd7599e53b20e (diff) | |
download | cpython-8377cd4fcd0d51d86834c9b0518d29aac3b49e18.zip cpython-8377cd4fcd0d51d86834c9b0518d29aac3b49e18.tar.gz cpython-8377cd4fcd0d51d86834c9b0518d29aac3b49e18.tar.bz2 |
Clean up code which checked presence of os.{stat,lstat,chmod} (#11643)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 0 insertions, 5 deletions
@@ -2266,7 +2266,6 @@ class PyBuildInstallLib(install_lib): return outfiles def set_file_modes(self, files, defaultMode, sharedLibMode): - if not self.is_chmod_supported(): return if not files: return for filename in files: @@ -2277,16 +2276,12 @@ class PyBuildInstallLib(install_lib): if not self.dry_run: os.chmod(filename, mode) def set_dir_modes(self, dirname, mode): - if not self.is_chmod_supported(): return for dirpath, dirnames, fnames in os.walk(dirname): if os.path.islink(dirpath): continue log.info("changing mode of %s to %o", dirpath, mode) if not self.dry_run: os.chmod(dirpath, mode) - def is_chmod_supported(self): - return hasattr(os, 'chmod') - class PyBuildScripts(build_scripts): def copy_scripts(self): outfiles, updated_files = build_scripts.copy_scripts(self) |