summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2010-08-08 17:58:53 (GMT)
committerThomas Heller <theller@ctypes.org>2010-08-08 17:58:53 (GMT)
commit864cc6703a7c4399295b3601f49e0065639443bf (patch)
tree03fc3dc987860d40c7959cdfcb700a8281832ef9 /setup.py
parent93d768d6328ae6c0a7dd207e5b1790df6686fd62 (diff)
downloadcpython-864cc6703a7c4399295b3601f49e0065639443bf.zip
cpython-864cc6703a7c4399295b3601f49e0065639443bf.tar.gz
cpython-864cc6703a7c4399295b3601f49e0065639443bf.tar.bz2
Fix issue5504: ctypes does now work with systems where mmap can't be
PROT_WRITE and PROT_EXEC.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ef6f2f6..ac37aa9 100644
--- a/setup.py
+++ b/setup.py
@@ -1639,8 +1639,7 @@ class PyBuildExt(build_ext):
'_ctypes/callbacks.c',
'_ctypes/callproc.c',
'_ctypes/stgdict.c',
- '_ctypes/cfield.c',
- '_ctypes/malloc_closure.c']
+ '_ctypes/cfield.c']
depends = ['_ctypes/ctypes.h']
if sys.platform == 'darwin':