summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2001-12-06 22:59:54 (GMT)
committerFred Drake <fdrake@acm.org>2001-12-06 22:59:54 (GMT)
commit9028d0a52529a8bc76868ade697511f29614b207 (patch)
treeef66dec6dba83cec240139ccdafbe09372961e2c /setup.py
parente3d7622fb3e595db29b690751a00406b0e3cf975 (diff)
downloadcpython-9028d0a52529a8bc76868ade697511f29614b207.zip
cpython-9028d0a52529a8bc76868ade697511f29614b207.tar.gz
cpython-9028d0a52529a8bc76868ade697511f29614b207.tar.bz2
Visious hackery to solve a build-control problem related to our use of
distutils for the library modules built as shared objects. A better solution appears possible, but with the threat that the distutils becomes more magical ("complex"). This closes SF bug #458343.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 183c45e..693d64c 100644
--- a/setup.py
+++ b/setup.py
@@ -172,6 +172,13 @@ class PyBuildExt(build_ext):
self.get_ext_filename(fullname))
os.remove(ext_filename)
+ # XXX -- This relies on a Vile HACK in
+ # distutils.command.build_ext.build_extension(). The
+ # _built_objects attribute is stored there strictly for
+ # use here.
+ for filename in self._built_objects:
+ os.remove(filename)
+
def get_platform (self):
# Get value of sys.platform
platform = sys.platform