summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-03-17 16:56:35 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-03-17 16:56:35 (GMT)
commit9b5abcd48c3f2277c8c328ff7d2db26b272618c5 (patch)
tree43926b63a723620d955ba31c7c8d50cbd8c1a593 /setup.py
parent84e87f379eb67330cf2cdd3e9ed78d55d5992384 (diff)
downloadcpython-9b5abcd48c3f2277c8c328ff7d2db26b272618c5.zip
cpython-9b5abcd48c3f2277c8c328ff7d2db26b272618c5.tar.gz
cpython-9b5abcd48c3f2277c8c328ff7d2db26b272618c5.tar.bz2
Tidy up the ordering of include and library directories, putting
/usr/local first and leaving /usr/include at the end. This addresses the comments in bug #232609.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 88e1c63..61c4fad 100644
--- a/setup.py
+++ b/setup.py
@@ -146,19 +146,19 @@ class PyBuildExt(build_ext):
def detect_modules(self):
# Ensure that /usr/local is always used
if '/usr/local/lib' not in self.compiler.library_dirs:
- self.compiler.library_dirs.append('/usr/local/lib')
+ self.compiler.library_dirs.insert(0, '/usr/local/lib')
if '/usr/local/include' not in self.compiler.include_dirs:
- self.compiler.include_dirs.append( '/usr/local/include' )
+ self.compiler.include_dirs.insert(0, '/usr/local/include' )
# lib_dirs and inc_dirs are used to search for files;
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib']
- inc_dirs = ['/usr/include'] + self.compiler.include_dirs
+ inc_dirs = self.compiler.include_dirs + ['/usr/include']
exts = []
platform = self.get_platform()
-
+
# Check for MacOS X, which doesn't need libm.a at all
math_libs = ['m']
if platform in ['Darwin1.2', 'beos']: