diff options
author | Ned Deily <nad@python.org> | 2016-02-24 13:59:16 (GMT) |
---|---|---|
committer | Ned Deily <nad@python.org> | 2016-02-24 13:59:16 (GMT) |
commit | b8da1a4feecc387b42d169be472e3a013cebdbc3 (patch) | |
tree | 4665acb27484418fb053da3615730699f361c1c8 /setup.py | |
parent | b118870490dd62e0706e8e610e99115c20e02bff (diff) | |
parent | 020250f91f61d752bed18117e0570c1425b5d595 (diff) | |
download | cpython-b8da1a4feecc387b42d169be472e3a013cebdbc3.zip cpython-b8da1a4feecc387b42d169be472e3a013cebdbc3.tar.gz cpython-b8da1a4feecc387b42d169be472e3a013cebdbc3.tar.bz2 |
Issue #25136: merge from 3.5
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 16 insertions, 0 deletions
@@ -136,6 +136,22 @@ def find_library_file(compiler, libname, std_dirs, paths): p = p.rstrip(os.sep) if host_platform == 'darwin' and is_macosx_sdk_path(p): + # Note that, as of Xcode 7, Apple SDKs may contain textual stub + # libraries with .tbd extensions rather than the normal .dylib + # shared libraries installed in /. The Apple compiler tool + # chain handles this transparently but it can cause problems + # for programs that are being built with an SDK and searching + # for specific libraries. Distutils find_library_file() now + # knows to also search for and return .tbd files. But callers + # of find_library_file need to keep in mind that the base filename + # of the returned SDK library file might have a different extension + # from that of the library file installed on the running system, + # for example: + # /Applications/Xcode.app/Contents/Developer/Platforms/ + # MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk/ + # usr/lib/libedit.tbd + # vs + # /usr/lib/libedit.dylib if os.path.join(sysroot, p[1:]) == dirname: return [ ] |