summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-12-06 15:57:16 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-12-06 15:57:16 (GMT)
commite7ffbb24e80800de3667a88af96d03f8c9717039 (patch)
treeb57c734a344c915d58b54857851e9e1152d6eb2c /setup.py
parent1a48ca8c53b80627ebf3c4215140cdc07152556d (diff)
downloadcpython-e7ffbb24e80800de3667a88af96d03f8c9717039.zip
cpython-e7ffbb24e80800de3667a88af96d03f8c9717039.tar.gz
cpython-e7ffbb24e80800de3667a88af96d03f8c9717039.tar.bz2
[Bug #480882] Remove now-pointless check for existence for _curses_panel.c;
Bugfix candidate.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9796d3f..727f3b9 100644
--- a/setup.py
+++ b/setup.py
@@ -472,8 +472,7 @@ class PyBuildExt(build_ext):
libraries = curses_libs) )
# If the curses module is enabled, check for the panel module
- if (os.path.exists('Modules/_curses_panel.c') and
- module_enabled(exts, '_curses') and
+ if (module_enabled(exts, '_curses') and
self.compiler.find_library_file(lib_dirs, 'panel')):
exts.append( Extension('_curses_panel', ['_curses_panel.c'],
libraries = ['panel'] + curses_libs) )